FullCount Touchscreen Degradation

Incident Report for 365 Retail Markets - System

Resolved

Dear Valued Partner,

All FullCount systems are now operational. Please contact FullCount Support (support@fullcount.net, 800-289-9636) if you have any questions or see any further issues.

We apologize again for this inconvenience and truly appreciate your partnership and patience.

Thank you,

FullCount
Posted Apr 30, 2026 - 08:43 EDT

Investigating

The FullCount Touchscreen is currently experiencing a degradation in service. We are investigating the issue and will provide an update as soon as possible.
Posted Apr 30, 2026 - 08:40 EDT
This incident affected: FullCount (Touchscreen).