Heartland has confirmed the issue was resolved completely on their end by 1:20 PM EST and we haven't seen any further impact. We will continue to work with Heartland once they publish their root cause analysis to identify any opportunities for enhancing customer experience based on their findings. If you have any questions, please contact 365 Support.
We apologize for the inconvenience to your business.
365 Retail Markets Support
Posted Nov 10, 2025 - 16:26 EST
Monitoring
We are beginning to see transaction completion as expected, through the Heartland Payment Gateway. Our team is currently working with Heartland to understand the root cause and get final resolution messaging before we officially resolve this incident.
If you have any questions, please contact 365 Support.
We apologize for the inconvenience to your business.
365 Retail Markets Support
Posted Nov 10, 2025 - 12:02 EST
Investigating
At approximately 10:30 A.M. EST, 365 Retail Markets began experiencing issues with the Heartland Payment Gateway, specifically impacting MM6 & Pico Devices. Our Team is currently working with Heartland to resolve this issue. More updates will be provided as they become available. If you have any questions, please contact 365 Support.
We apologize for the inconvenience to your business.
365 Retail Markets Support
Posted Nov 10, 2025 - 11:06 EST
This incident affected: V5 Platform (Credit Card Gateway).